Catégories
Start-up et applications

Résumé des actualités du SD Times: WhiteSource lance de nouvelles alertes basées sur les vulnérabilités, UniObjects gratuit pour Python de Rocket Software et Let’s Encrypt met en garde contre la compatibilité

WhiteSource a annoncé de nouvelles alertes basées sur les vulnérabilités conçues pour accélérer et simplifier le processus de gestion des vulnérabilités. Il offrira aux développeurs une flexibilité dans la gestion des alertes ainsi qu'une vue plus granulaire des problèmes, selon l'entreprise.

«Le nombre de vulnérabilités de sécurité connues a augmenté de façon exponentielle au cours des dernières années, et les équipes ont besoin d'outils améliorés pour les aider à gérer facilement l'augmentation drastique des alertes de vulnérabilité», a déclaré David Habusha, vice-président des produits chez WhiteSource.

Avec cette nouvelle fonctionnalité, les équipes peuvent obtenir plus de contrôle et une visibilité accrue dans le processus de gestion des alertes, sans ralentir le rythme de développement, selon WhiteSource.

Rocket Software lance des UniObjects gratuits pour Python
UniObjects for Python (UOPY) est une API Python côté client qui aide les entreprises à attirer et à retenir de nouveaux talents en programmation en permettant le développement rapide de nouvelles applications, selon le créateur d'offres Rocket Software.

Les programmeurs peuvent désormais développer une pile complète dans un seul langage moderne, utiliser l'ensemble de l'écosystème Python avec de nombreuses bibliothèques tierces et accéder à distance aux serveurs MultiValue en Python.

Let’s Encrypt vous avertit des problèmes de compatibilité avec la nouvelle autorité de certification
Let’s Encrypt a annoncé que, bien que le certificat racine DST Root X3 expire le 1er septembre 2021, Let’s Encrypt ne pourra compter que sur son propre certificat racine.

Cependant, certains logiciels qui n’ont pas été mis à jour depuis 2016 ne font toujours pas confiance au certificat racine de Let’s Encrypt, y compris les versions d’Android antérieures à la version 7.1.1.

À compter du 11 janvier 2021, l'équipe derrière le projet prévoit d'apporter des modifications à son API afin que les clients ACME servent, par défaut, une chaîne de certificats menant à ISRG Root X1.

Des détails supplémentaires sont disponibles ici.

Mise à jour hebdomadaire d'Apache
La semaine dernière, l'Apache Software Foundation a annoncé la sortie d'Apache Skywalking 8.2.0, Client JS 0.1.0 et Kubernetes Helm Chart 4.0.0 dans l'espace du moniteur de performances des applications.

Skywalking Kubernetes Helm Chart 4.0.0 permet de remplacer les fichiers de configuration par défaut et unifie les utilisations des différentes versions de SkyWalking.

Les autres versions d'Apache cette semaine incluent HBase 2.3.3, la version bêta de ShardingSphere ElasticJob 3.0.0, Jackrabbit 2.20.2, Commons VFS 2.7.0, etc.

Des détails supplémentaires sur toutes les versions sont disponibles ici.

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *